<!DOCTYPE html>
<!--[if lt IE 10]><html class="lt-ie10"><![endif]-->
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta http-equiv="cleartype" content="on">
<meta name="verification" content="0c36d0e5789b8e86826ca3023cf53b44" />
<script>
				if( window.location.hash ) {
			window.location.hash = encodeURI(window.location.hash).replace(/'/, "%27");
		}
	</script>
<meta name="description" content="The video reveals the White man making obscene sexual remarks about the Black man&#039;s mother and hurling racial slurs, using the n-word freely." />
<meta name="news_keywords" content="n-word, twisted tea, iced tea, ohio, covid, slur, social media, video shows, white man, black man, can of twisted tea, circle k, elyria, gas station, chronicle-telegram, racial slur, viral video, beatdown, circle k gas station, city of elyria, convenience store, ohio gas station, pandemic, racist slur, brawl, saying n-word, twitter user" />
<meta name="keywords" content="n-word, twisted tea, iced tea, ohio, covid, slur, social media, video shows, white man, black man, can of twisted tea, circle k, elyria, gas station, chronicle-telegram, racial slur, viral video, beatdown, circle k gas station, city of elyria, convenience store, ohio gas station, pandemic, racist slur, brawl, saying n-word, twitter user" />
<meta property="fb:app_id" content="2649681551948242" />
<meta name="p:domain_verify" content="c0809c6c9b1d4d37973dce032db72e5b" />
<meta name="msvalidate.01" content="92EB67C1B2C34F1A8BF5E0B29F8840DE" />
<title>Man Gets Beaten With Twisted Tea After Yelling Racial Slurs | Rare</title>
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//content.jwplatform.com' />
<link rel='dns-prefetch' href='//htlbid.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Rare &raquo; Feed" href="https://rare.us/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rare &raquo; Comments Feed" href="https://rare.us/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/rare.us\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0' href='https://rare.us/_static/??/wp-includes/css/dist/block-library/style.min.css,/wp-content/themes/wom-rare-platform/assets/brands/rare/single.css?m=1607466213' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='platform-fonts-css' href='//fonts.googleapis.com/css?family=Bitter%3A400i%2C700%7CMontserrat%3A700%7CSource+Sans+Pro%3A400%2C400i%2C700&#038;ver=5.6' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://rare.us/wp-content/mu-plugins/jetpack-9.2/css/jetpack.css?m=1606249613g' type='text/css' media='all' />
<script>window.themeSettings = {"ajaxUrl":"https:\/\/rare.us\/wp-admin\/admin-ajax.php","themeAjaxAction":"themeajax"}</script> <script>
		window.rare = window.rare || {"is_mobile":false}	</script>
<script id='utils-js-extra'>
var userSettings = {"url":"\/","uid":"0","time":"1609283900","secure":"1"};
</script>
<script id='localtime-js-extra'>
var localtime = {"translated_title":"This date and\/or time has been adjusted to match your timezone","locale":{"month_01":"January","month_02":"February","month_03":"March","month_04":"April","month_05":"May","month_06":"June","month_07":"July","month_08":"August","month_09":"September","month_10":"October","month_11":"November","month_12":"December","monthabbrev_01":"Jan","monthabbrev_02":"Feb","monthabbrev_03":"Mar","monthabbrev_04":"Apr","monthabbrev_05":"May","monthabbrev_06":"Jun","monthabbrev_07":"Jul","monthabbrev_08":"Aug","monthabbrev_09":"Sep","monthabbrev_10":"Oct","monthabbrev_11":"Nov","monthabbrev_12":"Dec","weekday_0":"Sunday","weekday_1":"Monday","weekday_2":"Tuesday","weekday_3":"Wednesday","weekday_4":"Thursday","weekday_5":"Friday","weekday_6":"Saturday","weekdayabbrev_01":"Sun","weekdayabbrev_02":"Mon","weekdayabbrev_03":"Tue","weekdayabbrev_04":"Wed","weekdayabbrev_05":"Thu","weekdayabbrev_06":"Fri","weekdayabbrev_07":"Sat"}};
</script>
<script type='text/javascript' src='https://rare.us/_static/??-eJx9yksKgDAMBNALqVHRuhLPIjVISho/TRFvbxeCbhQGZmAeHGtOYjlOGMClbBH3867CkxQuZPCHck/zPip+4ajE4X3aRRRFYeU4kwTgxY6s5PFZiQ6+r0zZNcbUVesunhw9RQ=='></script>
<!--[if lt IE 10]>
<script src='//cdnjs.cloudflare.com/ajax/libs/dom4/1.8.3/dom4.js?ver=5.6' id='IEfallbacks-js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script src='//cdnjs.cloudflare.com/ajax/libs/respond.js/1.1.0/respond.min.js?ver=5.6' id='IEfallbacksRespond-js'></script>
<![endif]-->
<script type='text/javascript' src='https://rare.us/wp-content/themes/wom-rare-platform/assets/brands/shared/taboola-head.min.js?m=1593395549g'></script>
<script src='https://htlbid.com/v2/rare.min.js?ver=20180925' id='htlbid-js'></script>
<script id='htlbid-js-after'>
var htlbid = htlbid || {}; htlbid.cmd = htlbid.cmd || [];
htlbid.cmd.push(function() {
            htlbid.setTargeting('cat', "rare-news");
htlbid.setTargeting('isHome', "false");
htlbid.setTargeting('isArticle', "true");
htlbid.setTargeting('isPage', "false");
htlbid.setTargeting('postID', "939282");
htlbid.setTargeting('programmatic', "yes");
htlbid.setTargeting('customer', "None");
htlbid.setTargeting('isSearch', "false");
htlbid.setTargeting('is404', "false");
htlbid.setTargeting('site', "rare");
          });
</script>
<link rel="https://api.w.org/" href="https://rare.us/wp-json/" /><link rel="alternate" type="application/json" href="https://rare.us/wp-json/wp/v2/posts/939282" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rare.us/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rare.us/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6" />
<link rel="canonical" href="https://rare.us/rare-news/man-beaten-with-twisted-tea/" />
<link rel='shortlink' href='https://bit.ly/3o0e8t1' />
<link rel="alternate" type="application/json+oembed" href="https://rare.us/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frare.us%2Frare-news%2Fman-beaten-with-twisted-tea%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://rare.us/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frare.us%2Frare-news%2Fman-beaten-with-twisted-tea%2F&#038;format=xml" />
<script>
var GTMDataLayer = [{"Primary Category":"rare-news","Article Type":"Article","Post Type":"post","Post Author":"lauren-pineda","Published Date":"<span class=\"localtime\" data-ltformat=\"Y-m-d\" data-lttime=\"&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T22:02:52+00:00&quot;&gt;2020-12-29T22:02:52+00:00&lt;\/span&gt;\"><span class=\"localtime\" data-ltformat=\"Y-m-d\" data-lttime=\"2020-12-29T22:02:52+00:00\">2020-12-29<\/span><\/span>","Post Republished":false,"Post Tags":"beatdown black-man brawl can-of-twisted-tea chronicle-telegr","Category":"rare-news"}];
</script>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-T7HN8PV"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','GTMDataLayer','GTM-T7HN8PV');</script>
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
<meta property="rare:category_slug" content="rare-news" />
<meta property="rare:category_name" content="Rare News" />
<meta property="FacebookShareMessage" content="The video reveals the White man making obscene sexual remarks about the Black man&#039;s mother and hurling racial slurs, using the n-word freely." />
<meta property="TwitterShareMessage" content="The video reveals the White man making obscene sexual remarks about the Black man&#039;s mother and hurling racial slurs, using the n-word freely." />
<script type="text/javascript">     var _qevents = _qevents || [];     (function() {         var elem = document.createElement("script");         elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge")                     + ".quantserve.com/quant.js";         elem.async = true;         elem.type = "text/javascript";         var scpt = document.getElementsByTagName("script")[0];         scpt.parentNode.insertBefore(elem, scpt);     })();</script><script>  var _comscore = _comscore || [];  _comscore.push({ c1: "2", c2: "6036336" });  (function() {      var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;      s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";      el.parentNode.insertBefore(s, el);  })();</script><noscript>  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6036336&cv=2.0&cj=1" /></noscript><script>  !function(f,b,e,v,n,t,s)  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?  n.callMethod.apply(n,arguments):n.queue.push(arguments)};  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version="2.0";  n.queue=[];t=b.createElement(e);t.async=!0;  t.src=v;s=b.getElementsByTagName(e)[0];  s.parentNode.insertBefore(t,s)}(window, document,"script",  "https://connect.facebook.net/en_US/fbevents.js");  fbq("init", "1329382090484650");  fbq("track", "PageView");</script><noscript><img height="1" width="1" style="display:none"  src="https://www.facebook.com/tr?id=1329382090484650&ev=PageView&noscript=1"/></noscript><meta property="og:site_name" content="Rare" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="og:url" content="https://rare.us/rare-news/man-beaten-with-twisted-tea/" />
<meta property="og:title" content="Man Gets Beaten With Twisted Tea After Yelling Racial Slurs" />
<meta property="og:description" content="We all know to really and truly be careful about what you ask for- because you just might actually get it. And in this case, this guy definitely deserved it. It is never okay to use the N-word, in any situation by anyone, and this guy was not only asking to get his butt whooped&hellip;" />
<meta property="article:published_time" content="2020-12-29T22:02:52+00:00" />
<meta property="article:modified_time" content="2020-12-29T22:02:52+00:00" />
<meta property="article:author" content="https://rare.us/voices/lauren-pineda/" />
<meta property="article:section" content="Rare News" />
<meta property="article:tag" content="beatdown" />
<meta property="article:tag" content="black man" />
<meta property="article:tag" content="brawl" />
<meta property="article:tag" content="can of twisted tea" />
<meta property="article:tag" content="chronicle-telegram" />
<meta property="article:tag" content="Circle K" />
<meta property="article:tag" content="Circle K gas station" />
<meta property="article:tag" content="city of elyria" />
<meta property="article:tag" content="convenience store" />
<meta property="article:tag" content="CoVid" />
<meta property="article:tag" content="elyria" />
<meta property="article:tag" content="gas station" />
<meta property="article:tag" content="Iced Tea" />
<meta property="article:tag" content="n-word" />
<meta property="article:tag" content="Ohio" />
<meta property="article:tag" content="ohio gas station" />
<meta property="article:tag" content="Pandemic" />
<meta property="article:tag" content="racial slur" />
<meta property="article:tag" content="racist slur" />
<meta property="article:tag" content="saying n-word" />
<meta property="article:tag" content="slur" />
<meta property="article:tag" content="Social media" />
<meta property="article:tag" content="twisted tea" />
<meta property="article:tag" content="twitter user" />
<meta property="article:tag" content="Video Shows" />
<meta property="article:tag" content="viral video" />
<meta property="article:tag" content="white man" />
<meta property="og:image" content="https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg" />
<meta property="og:image:width" content="616" />
<meta property="og:image:height" content="411" />
<link rel="amphtml" href="https://rare.us/rare-news/man-beaten-with-twisted-tea/amp/"><link rel="icon" href="https://rare.us/wp-content/uploads/sites/3/2020/05/cropped-cropped-mock-siteicon.png?w=32" sizes="32x32" />
<link rel="icon" href="https://rare.us/wp-content/uploads/sites/3/2020/05/cropped-cropped-mock-siteicon.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://rare.us/wp-content/uploads/sites/3/2020/05/cropped-cropped-mock-siteicon.png?w=180" />
<meta name="msapplication-TileImage" content="https://rare.us/wp-content/uploads/sites/3/2020/05/cropped-cropped-mock-siteicon.png?w=270" />
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityofPage":{"@type":"WebPage","@id":"https:\/\/rare.us\/rare-news\/man-beaten-with-twisted-tea\/"},"headline":"Man Gets Beaten With Twisted Tea After Yelling Racial Slurs","image":{"@type":"ImageObject","url":"https:\/\/rare.us\/wp-content\/uploads\/sites\/3\/2020\/12\/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg","height":800,"width":1200},"datePublished":"2020-12-29T16:02:52+00:00","dateModified":"2020-12-29T16:02:52+00:00","author":{"@type":"Person","name":"Lauren Pineda"},"publisher":{"@type":"Organization","name":"Rare","logo":{"@type":"ImageObject","url":"https:\/\/rare.us\/wp-content\/themes\/wom-rare-platform\/assets\/brands\/rare\/img\/rare-logo-amp.png","width":152,"height":60}},"description":"The video reveals the White man making obscene sexual remarks about the Black man's mother and hurling racial slurs, using the n-word freely.","keywords":"beatdown,black-man,brawl,can-of-twisted-tea,chronicle-telegram,circle-k,circle-k-gas-station,city-of-elyria,convenience-store,covid,elyria,gas-station,iced-tea,n-word,ohio,ohio-gas-station,pandemic,racial-slur,racist-slur,saying-n-word,slur,social-media,twisted-tea,twitter-user,video-shows,viral-video,white-man","articleBody":"We all know to really and truly be careful about what you ask for- because you just might actually get it. And in this case, this guy definitely deserved it. It is never okay to use the N-word, in any situation by anyone, and this guy was not only asking to get his butt whooped by his actions but he stupidly, literally asked to get beat up.\r\n\r\nThis viral video shows a White man, seemingly wasted (and if not, then causing an unnecessary disturbance and ruckus) at a Circle K gas station in Elyria, Ohio, hurling profane words at the customer behind him, who is a Black man. The video reveals the White man making obscene sexual remarks about the Black man's mother and hurling racial slurs, using the n-word freely.\r\nCustomer Gets Beatdown With Twisted Tea For Saying N-Word\r\nhttps:\/\/twitter.com\/terencessb\/status\/1342002633679097858\r\n\r\nThe Black man at first does his best to ignore this guy in front of him, because anyone with decent common sense wouldn't waste their time on an idiot making racist slurs at a convenience store. But then the White customer just takes it too far. As the victim of the racial slurs grabs a can of Twisted Tea, which I assume he came to the Ohio gas station intending to grab a quick drink and go home to relax, the aggressor taunts his victim, literally asking him to smack him in the face.\r\n\r\nThe patient, but obviously irritated customer loads up into a cautioning stance, giving this idiot one more chance to actually shut up. But of course, the dumb-dumb keeps popping off, and so the tired customer goes at him with the spiked iced tea. The White man is totally thrown off, and as the fight continues on the floor, the Black man is clearly stronger and in more control of the situation.\r\n\r\n\"I asked you not to call me a [n-word],\" he says, as he holds the perpetrator on the floor. He picks him up and whisks him off towards the exit, not entertaining the situation any longer.\r\n\r\nI have no idea what makes it okay for this guy to do this in the city of Elyria, but this isn't okay anywhere, ever. According to the Chronicle-telegram, a local newspaper, the incident was not reported to the police, but the video went viral on social media. One Twitter user commented,\"This is what happens when y\u2019all use the n-word freely. Others think it\u2019s ok to. So when y\u2019all make music whatever it is , just know they are listening and mimicking our language and adapting to it. Personally why I hate the word because I know this will happen.\u201d\r\nTwitter User On Saying N-Word\r\nhttps:\/\/twitter.com\/HoneybLved\/status\/1342144174838194177\r\n\r\nAnd I won't fail to mention that the reasonable guy was wearing a face mask, while his oppressor wasn't. Let's not forget that COVID is still haunting our country, but even a pandemic isn't going to stop just because of a brawl. Nevertheless, this was handled with as much class as possible, and I have to hand it to the victim for keeping his cool and not wasting any more time than he needed to on someone like that.\r\nWatch: Racist Woman Yells at Asian Drugstore Staff For \u201cSpeaking Chinese\u201d in Front of Her","articleSection":"Rare News"}</script>
</head>
<body class="post-template-default single single-post postid-939282 single-format-standard group-blog rare-evolution rare-news">
<script>window.fbAsyncInit = function() {FB.init({appId: "2649681551948242", xfbml: true, version: "v8.0", autoLogAppEvents : true});};</script><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js"></script> <script>
		;(function(window, document) {
		    'use strict';

		    var file = 'https://rare.us/wp-content/themes/wom-rare-platform/assets/img/svg-global.svg',
		    	label = "rare_inlineSVGdataV3",
		        revision = 18;
		    if (!document.createElementNS || !document.createElementNS('http://www.w3.org/2000/svg', 'svg').createSVGRect)
		        return true;

		    var isLocalStorage = 'localStorage' in window && window['localStorage'] !== null,
		        request,
		        data,
		        insertIT = function() {
		            document.body.insertAdjacentHTML('afterbegin', data);
		        },
		        insert = function() {
		            if (document.body) insertIT();
		            else document.addEventListener('DOMContentLoaded', insertIT);
		        };

		    if (isLocalStorage && localStorage.getItem('inlineSVGrev') == revision) {
		        data = localStorage.getItem(label);
		        if (data) {
		            insert();
		            return true;
		        }
		    }

		    try {
		        request = new XMLHttpRequest();
		        request.open('GET', file, true);
		        request.onload = function() {
		            if (request.status >= 200 && request.status < 400) {
		                data = request.responseText;
		                insert();
		                if (isLocalStorage) {
		                    localStorage.setItem(label, data);
		                    localStorage.setItem('inlineSVGrev', revision);
		                }
		            }
		        }
		        request.send();
		    } catch (e) {}
		}(window, document));
	</script>
<script>
	window.rare = window.rare || {};
	window.rare.pageData = {
	"brandName": "rare",
	"brandFbPage": "RareUSA",
	"brandTwPage": "rare",
	"gaProfile": "UA-119400595-1",
	"pageName": "man-beaten-with-twisted-tea",
	"pageTitle": "Man Gets Beaten With Twisted Tea After Yelling Racial Slurs",
	"pageURL": "https://rare.us/rare-news/man-beaten-with-twisted-tea/",
	"guid": "https://rare.us/?p=939282",
	"featuredImage": "https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg",
	"featuredImageMeta": {"width":1200,"height":800},
	"featuredImageCredit": "Twitter via @terencessb",
	"pagePostType": "post",
	"pagePostType2": "single-post",
	"primaryCategory": {"name":"Rare News","slug":"rare-news","id":"478832"},
	"pageCategories": [{"name":"Rare News","slug":"rare-news","id":"478832"}],
	"pageTopLevelCategories": [{"name":"Rare News","slug":"rare-news","id":"478832"}],
	"delimitedCategories": "Rare News",
	"delimitedTopLevelCategories": "Rare News",
	"pageTags": ["beatdown","black-man","brawl","can-of-twisted-tea","chronicle-telegram","circle-k","circle-k-gas-station","city-of-elyria","convenience-store","covid","elyria","gas-station","iced-tea","n-word","ohio","ohio-gas-station","pandemic","racial-slur","racist-slur","saying-n-word","slur","social-media","twisted-tea","twitter-user","video-shows","viral-video","white-man"],
	"delimitedTags": "beatdown|black-man|brawl|can-of-twisted-tea|chronicle-telegram|circle-k|circle-k-gas-station|city-of-elyria|convenience-store|covid|elyria|gas-station|iced-tea|n-word|ohio|ohio-gas-station|pandemic|racial-slur|racist-slur|saying-n-word|slur|social-media|twisted-tea|twitter-user|video-shows|viral-video|white-man",
	"pageAuthors": [{"firstName":"Lauren","lastName":"Pineda","twitter":"laurentaypineda","id":922621,"guid":"https://rare.us/?p=922621"}],
	"delimitedAuthors": "Lauren Pineda",
	"pagePostAuthor": "Lauren Pineda",
	"pagePostDate": "2020-12-29 16:02:52",
	"pageModifiedDate": "2020-12-29 16:02:52",
	"facebookShareMessage": "",
	"twitterShareMessage": "",
	"pageExperience": "Rare V3",
	"mediaUrls": ["https://rumble.com/embed/vqsk0/?pub=4","https://twitter.com/terencessb/status/1342002633679097858","https://twitter.com/HoneybLved/status/1342144174838194177"],
	"pageVideoType": "rumble",
	"pageHasVideo": "1",
	"wordCount": "620",
	"postCountOnPage": "1",
	"postCountTotal": "0",
	};
</script>

<script src="//rare.us/wp-content/themes/wom-rare-platform/js/ga-f1m.js?version=018"></script>
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<div class="background-cover hidden-xs"><div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_Desktop_Skin" data-prebid="RARE_Desktop_Skin" data-sizes="0x0:|768x0:1x1"></div></div></div>
<div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_Desktop_Interstitial" data-prebid="RARE_Desktop_Interstitial" data-sizes="0x0:|768x0:1x1" data-eager></div></div> 
<div class="body-wrap">
<div class="menu-container menu-container--alt menu-wrap">
<nav id="site-navigation" class="main-nav-multi rare-title" role="navigation">
<button class="main-nav-multi__close close">
<label for="" class="screen-reader-text">Close Menu</label>
<svg class="icon"><use xlink:href="#icon-close"></use></svg>
</button>
<a id="menuTrendingLink" href="#" class="menu-trending">
<span class="menu-trending__title rare-title">Trending</span>
<h3 id="menuTrendingTitle" class="menu-trending__headline rare-headline">
</h3>
<span class="menu-trending__cta rare-subtitle">
<svg class="icon"><use xlink:href="#icon-angle-right-circle"></use></svg><span>Read Story</span>
</span>
</a>
<div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="main-nav-multi__list"><li data-depth="" id="menu-item-25237" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children topics menu-item--first-level"><span class="menu-item__wrap"><a><div class="icon-wrap icon-wrap--menu-discuss"><img class="icon icon-menu-discuss" src="https://rare.us/wp-content/themes/wom-rare-platform/assets/img/svg-menu/menu-discuss.svg"></div>Topics</a></span>
<ul class="sub-menu">
<li data-depth="" id="menu-item-107039" class="menu-item menu-item-type-custom menu-item-object-custom rare-news menu-item--second-level"><span class="menu-item__wrap"><a href="http://www.rare.us/rare-news/">Rare News</a></span></li>
<li data-depth="" id="menu-item-107040" class="menu-item menu-item-type-custom menu-item-object-custom rare-people menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/people">Rare People</a></span></li>
<li data-depth="" id="menu-item-107041" class="menu-item menu-item-type-custom menu-item-object-custom rare-animals menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/rare-animals">Rare Animals</a></span></li>
<li data-depth="" id="menu-item-154252" class="menu-item menu-item-type-custom menu-item-object-custom rare-entertainment menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/entertainment-and-culture/">Rare Entertainment</a></span></li>
<li data-depth="" id="menu-item-147238" class="menu-item menu-item-type-taxonomy menu-item-object-category rare-life menu-item--second-level"><span class="menu-item__wrap"><a href="https://rare.us/rare-life/">Rare Life</a></span></li>
</ul>
</li>
<li data-depth="" id="menu-item-78" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children super-stories menu-item--first-level"><span class="menu-item__wrap"><a><div class="icon-wrap icon-wrap--menu-page"><img class="icon icon-menu-page" src="https://rare.us/wp-content/themes/wom-rare-platform/assets/img/svg-menu/menu-page.svg"></div>Super Stories</a></span>
<ul class="sub-menu">
<li data-depth="" id="menu-item-107049" class="menu-item menu-item-type-custom menu-item-object-custom patriotism menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/tag/patriotism/">Patriotism</a></span></li>
<li data-depth="" id="menu-item-236051" class="menu-item menu-item-type-custom menu-item-object-custom rare-under-40-awards menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/rare-under-40-awards/">Rare Under 40 Awards</a></span></li>
<li data-depth="" id="menu-item-107050" class="menu-item menu-item-type-custom menu-item-object-custom rare-under-40-poll menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/tag/rare-under-40/">Rare Under 40 Poll</a></span></li>
<li data-depth="" id="menu-item-107051" class="menu-item menu-item-type-custom menu-item-object-custom veterans menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/tag/veterans/">Veterans</a></span></li>
<li data-depth="" id="menu-item-730290" class="menu-item menu-item-type-custom menu-item-object-custom heroes-in-uniforms menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/tag/hero/">Heroes in Uniforms</a></span></li>
<li data-depth="" id="menu-item-235973" class="menu-item menu-item-type-custom menu-item-object-custom the-royal-family menu-item--second-level"><span class="menu-item__wrap"><a href="http://rare.us/rare-people/the-royal-family/">The Royal Family</a></span></li>
</ul>
</li>
<li data-depth="" id="menu-item-107042" class="menu-item menu-item-type-custom menu-item-object-custom rare-country menu-item--first-level"><span class="menu-item__wrap"><a href="http://rarecountry.com"><div class="icon-wrap icon-wrap--menu-page"><img class="icon icon-menu-page" src="https://rare.us/wp-content/themes/wom-rare-platform/assets/img/svg-menu/menu-page.svg"></div>Rare Country</a></span></li>
<li data-depth="" id="menu-item-182392" class="menu-item menu-item-type-custom menu-item-object-custom rare-jobs menu-item--first-level"><span class="menu-item__wrap"><a href="http://www.wideopenmediagroup.com/careers/"><div class="icon-wrap icon-wrap--menu-user"><img class="icon icon-menu-user" src="https://rare.us/wp-content/themes/wom-rare-platform/assets/img/svg-menu/menu-user.svg"></div>Rare jobs</a></span></li>
</ul></div> </nav>
</div>

<div class="content-wrap">
<header class="header">
<div class="header__inner">
<div class="header__item header__item--first">
<div class="header__logo">
<a href="https://rare.us" class="site-logo" rel="home">
<img class="site-logo__icon" src="https://rare.us/wp-content/themes/wom-rare-platform/assets/brands/rare/img/rare-logo.svg" />
</a>
</div>
<div class="header__menu">
<a href="#" class="menu-push close">
<span class="menu-wrap">
<svg class="menu-push__icon"><use xlink:href="#icon-menu"></use></svg>
<span class="menu-push__text">Menu</span>
</span>
</a>
</div>
</div>
<div class="header__item scroll-hide">
<div class="utility__item">
<div class="search-wrap">
<a href="#" class="search-toggle toggle close">
<svg class="utility__icon utility__icon--search icon icon-search"><use xlink:href="#icon-search"></use></svg>
<svg class="utility__icon utility__icon--search icon icon-close"><use xlink:href="#icon-close"></use></svg>
</a>
<div class="search-container toggle-container">
<div class="site-search">
<form role="search" method="get" class="search-form" action="https://rare.us/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form> </div>
</div>
</div>
</div>
<a href="https://www.facebook.com/RareUSA" id="facebook" class="utility__item" title="Find Rare on Facebook">
<svg class="utility__icon utility__icon--facebook"><use xlink:href="#icon-facebook"></use></svg>
</a>
<a href="https://twitter.com/rare" id="twitter" class="utility__item" title="Find Rare on Twitter">
<svg class="utility__icon utility__icon--twitter"><use xlink:href="#icon-twitter"></use></svg>
</a>
</div>
<div class="header__item header__item--last reveal">
<a href="https://rare.us/rare-news/trump-pardons-charles-kushner/" class="callout" onclick="ga_universal('send', 'event', 'Related', 'Dogear', window.location.href);">
<img class="callout__image" src="https://rare.us/wp-content/uploads/sites/3/2020/12/Trump-Pardons-Jared-Kushners-Father-Who-Paid-Prostitute-To-Seduce.jpg?w=100&#038;h=60&#038;crop=1" alt="Trump Pardons Jared Kushner&#8217;s Father, Who Paid Prostitute To Seduce">
<span class="callout__text">
<span class="callout__label">Read this Next</span>
<h2 class="callout__title">Trump Pardons Jared Kushner&#039;s Father, Who Paid Prostitute To Seduce Brother-In-Law</h2>
</span>
</a>
</div>
<div class="header__item header__item--last hidden-xs">
<a href="/notifications" class="push-cta" id="uaCta">
<svg class="push-cta__icon"><use xlink:href="#icon-bell"></use></svg>
<span class="push-cta__text rare-title hidden-xs hidden-sm" id="uaCtaText">
</span>
<svg class="push-cta__icon push-cta__icon--arrow hidden-xs hidden-sm"><use xlink:href="#icon-angle-down-gray"></use></svg>
</a>
</div>
</div>
</header>
<div class="single-v3 single-v3--default">
<main class="single-v3__inner">
<div class="single-v3__container single-v3__container--flex"><div id="flexParentFLX01" class="flex-ad text-center homepage-standard__block"> <div class="flex-ad__text rare-title">Advertisement</div> <div class="flex-ad__wrap"> <div class="ad-holder"><div class="htl-ad" data-unit="RARE_Desktop_Leaderboard_1" data-prebid="RARE_Desktop_Leaderboard_1" data-sizes="0x0:|768x0:728x90|990x0:728x90,970x90,970x250" data-eager></div> </div> </div></div></div><div class="post-header-v3 default signup-anchor">
<div class="single-v3__container post-header-v3__top">

<div class="breadcrumbs rare inverse rare-title">
<ul class="breadcrumbs__list">
<li class="cat-item--parent cat-item"><a href="https://rare.us" title="Home">Home</a></li>
<li class="cat-item--parent cat-item current-cat"><a href="https://rare.us/rare-news/" title="Rare News">
Rare News </a></li>
<li class="cat-item cat-item-38194044"><a href="https://rare.us/rare-news/across-the-u-s-a/" title="ONLY use if none of the more specific ones fit">Across the U.S.A.</a>
</li>
<li class="cat-item cat-item-11416"><a href="https://rare.us/rare-news/around-the-world/" title="ONLY use if none of the more specific ones fit">Around the world</a>
</li>
<li class="cat-item cat-item-543401395"><a href="https://rare.us/rare-news/business/" title="Strictly business -- Companies doing things: Apple release, advertising, PR stunts">Business</a>
</li>
<li class="cat-item cat-item-372322"><a href="https://rare.us/rare-news/caught-on-video/" title="ONLY if it doesn&#039;t fit another category">Caught on video</a>
</li>
<li class="cat-item cat-item-18174"><a href="https://rare.us/rare-news/crime-and-punishment/" title="News about trials and sentencing mainly (when it doesn&#039;t fit elsewhere)">Crime and punishment</a>
</li>
<li class="cat-item cat-item-1342"><a href="https://rare.us/rare-news/education/" title="News (not opinion) about schools, curriculum, Common Core, serious education ISSUES. Not political.">Education</a>
</li>
<li class="cat-item cat-item-630929"><a href="https://rare.us/rare-news/energy-future/" title="News (not opinion) about innovation, alternative energy, oil &amp; gas, Keystone pipeline, etc. ">Energy future</a>
</li>
<li class="cat-item cat-item-553664"><a href="https://rare.us/rare-news/god-bless-america/" title="ONLY positive stories about Americans doing it &quot;their way&quot;">God Bless America</a>
</li>
<li class="cat-item cat-item-86667"><a href="https://rare.us/rare-news/health-and-medicine/" title="Ebola, miracle operations, health studies (beer/wine good for us), etc.">Health and medicine</a>
</li>
<li class="cat-item cat-item-678"><a href="https://rare.us/rare-news/history/" title="historical anniversaries, revisiting the past, learning from the past, etc.">History</a>
</li>
<li class="cat-item cat-item-42518"><a href="https://rare.us/rare-news/national-security/" title="News (not opinion) about terrorism, border security, the homeland. Not political.">National security</a>
</li>
<li class="cat-item cat-item-758698"><a href="https://rare.us/rare-news/race-in-america/">Race in America</a>
</li>
<li class="cat-item cat-item-130339049"><a href="https://rare.us/rare-news/rare-exclusive/">Rare exclusive</a>
</li>
<li class="cat-item cat-item-280522"><a href="https://rare.us/rare-news/science-and-nature/" title="Stories about the WONDER of the natural world and space">Science and nature</a>
</li>
<li class="cat-item cat-item-67"><a href="https://rare.us/rare-news/sports/" title="sports news, athletes doing things, sports-related stories that don&#039;t fit in another category">Sports</a>
</li>
<li class="cat-item cat-item-17460"><a href="https://rare.us/rare-news/the-media/" title="when it&#039;s ABOUT the reporter/host, journalists making news">The media</a>
</li>
<li class="cat-item cat-item-277292"><a href="https://rare.us/rare-news/whats-wrong-with-people/" title="ONLY weird crimes">What&#039;s wrong with people</a>
</li>
<li class="cat-item--post cat-item has-tax"><a href="https://rare.us/rare-news/man-beaten-with-twisted-tea/">Man Gets Beaten With Twisted Tea After Yelling Racial Slurs</a></li>
</ul>
</div>

</div>
<div class="post-header-v3__headline-wrap sticky-anchor single-v3__container">

<h1 class="post-header-v3__headline rare-headline single-v3__max-container">Man Gets Beaten With Twisted Tea After Yelling Racial Slurs</h1>


<span class="post-header-v3__date rare-note">
<span class="author-name">
<a rel="author" class="author-name__link rare-subtitle" href="https://rare.us/voices/lauren-pineda/">Lauren Pineda</a><span class="comma">,</span>
</span>
<time datetime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T22:02:52+00:00&quot;&gt;2020-12-29T22:02:52+00:00&lt;/span&gt;&quot;&gt;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;2020-12-29T22:02:52+00:00&quot;&gt;December 29, 2020&lt;/span&gt;&lt;/span&gt; &lt;span class=&quot;localtime&quot; data-ltformat=&quot;g:i a&quot; data-lttime=&quot;2020-12-29T22:02:52+00:00&quot;&gt;4:02 pm&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T22:02:52+00:00&quot;&gt;2020-12-29T22:02:52+00:00&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="2020-12-29T22:02:52+00:00">December 29, 2020</span></span> <span class="localtime" data-ltformat="g:i a" data-lttime="2020-12-29T22:02:52+00:00">4:02 pm</span></time>
</span>

<iframe class="sticky rare-deferred post-header-v3__social single-v3__item" data-src="/widgets/sharing-v2?version=circle" width="100%" marginwidth="0" marginheight="0" scrolling="no" frameborder="0" id="sharing" data-direction="left"></iframe>

<span class="post-header-v3__cta sticky single-v3__item--alt" data-direction="right">
<span>
<div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_Desktop_MedRec_1" data-prebid="RARE_Desktop_MedRec_1" data-sizes="0x0:|1400x0:300x250,300x600,300x1050,336x280" data-refresh="viewable" data-refresh-secs="45"></div></div> </span>
<span class="post-header-v3__related">
<h3 class="post-header-v3__related-title rare-title">Stories for you</h3><div class="related-v3" id="relatedV3">
<div class="post-card-v3 compact">
<a class="post-card-v3__image" href="https://rare.us/rare-news/trump-pardons-charles-kushner/" onclick="ga_universal('send', 'event', 'V3 - Related', 'Clicked', 'https://rare.us/rare-news/trump-pardons-charles-kushner/')">
<img src="https://rare.us/wp-content/uploads/sites/3/2020/12/Trump-Pardons-Jared-Kushners-Father-Who-Paid-Prostitute-To-Seduce.jpg?w=409&#038;h=225&#038;crop=1" alt="Trump Pardons Jared Kushner&#8217;s Father, Who Paid Prostitute To Seduce Brother-In-Law">
</a>
<div class="post-card-v3__text">
<a href="https://rare.us/rare-news/" class="rare-title post-card-v3__cat" title="Read more stories in Rare News">Rare News</a> <h4 class="post-card-v3__headline">
<a class="rare-headline" href="https://rare.us/rare-news/trump-pardons-charles-kushner/" title="Read more about Trump Pardons Jared Kushner&#8217;s Father, Who Paid Prostitute To Seduce Brother-In-Law">Trump Pardons Jared Kushner&#8217;s Father, Who Paid Prostitute To Seduce Brother-In-Law</a>
</h4>
<div class="post-card-v3__date rare-note">
<span class="author-name">
<a rel="author" class="author-name__link rare-subtitle" href="https://rare.us/voices/lauren-pineda/">Lauren Pineda</a><span class="comma">,</span>
</span>
<time datetime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T18:28:44+00:00&quot;&gt;2020-12-29T18:28:44+00:00&lt;/span&gt;&quot;&gt;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;2020-12-29T18:28:44+00:00&quot;&gt;December 29, 2020&lt;/span&gt;&lt;/span&gt; &lt;span class=&quot;localtime&quot; data-ltformat=&quot;g:i a&quot; data-lttime=&quot;2020-12-29T18:28:44+00:00&quot;&gt;12:28 pm&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T18:28:44+00:00&quot;&gt;2020-12-29T18:28:44+00:00&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="2020-12-29T18:28:44+00:00">December 29, 2020</span></span> <span class="localtime" data-ltformat="g:i a" data-lttime="2020-12-29T18:28:44+00:00">12:28 pm</span></time>
</div>
<div class="post-card-v3 post-card-v3__sharing">
<div class="post-card-v3__share-button post-card-v3__share-button--blank">
<div onclick="ga_universal('send', 'event', 'V3 - Related', 'Like', 'https://rare.us/rare-news/trump-pardons-charles-kushner/')" class="fb-like" data-href="https://rare.us/rare-news/trump-pardons-charles-kushner/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="false" data-share="false"></div>
</div>
<div onclick="ga_universal('send', 'event', 'V3 - Related', 'Share', 'https://rare.us/rare-news/trump-pardons-charles-kushner/')" data-link="https://rare.us/rare-news/trump-pardons-charles-kushner/" class="rare-share post-card-v3__share-button"><svg class="icon"><use xlink:href="#icon-share-arrow"></use></svg> <span>| Share</span></div>
</div>
</div>
</div>
<div class="post-card-v3 compact">
<a class="post-card-v3__image" href="https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/" onclick="ga_universal('send', 'event', 'V3 - Related', 'Clicked', 'https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/')">
<img src="https://rare.us/wp-content/uploads/sites/3/2020/12/RARE-34.jpg?w=409&#038;h=225&#038;crop=1" alt="Donald Trump and Michelle Obama Named Most Admired in 2020">
</a>
<div class="post-card-v3__text">
<a href="https://rare.us/rare-news/" class="rare-title post-card-v3__cat" title="Read more stories in Rare News">Rare News</a> <h4 class="post-card-v3__headline">
<a class="rare-headline" href="https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/" title="Read more about Donald Trump and Michelle Obama Named Most Admired in 2020">Donald Trump and Michelle Obama Named Most Admired in 2020</a>
</h4>
<div class="post-card-v3__date rare-note">
<span class="author-name">
<a rel="author" class="author-name__link rare-subtitle" href="https://rare.us/voices/silkejasso/">Silke Jasso</a><span class="comma">,</span>
</span>
<time datetime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T18:13:53+00:00&quot;&gt;2020-12-29T18:13:53+00:00&lt;/span&gt;&quot;&gt;&lt;span class=&quot;localtime&quot; data-ltformat=&quot;F j, Y&quot; data-lttime=&quot;2020-12-29T18:13:53+00:00&quot;&gt;December 29, 2020&lt;/span&gt;&lt;/span&gt; &lt;span class=&quot;localtime&quot; data-ltformat=&quot;g:i a&quot; data-lttime=&quot;2020-12-29T18:13:53+00:00&quot;&gt;12:13 pm&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="&lt;span class=&quot;localtime&quot; data-ltformat=&quot;c&quot; data-lttime=&quot;2020-12-29T18:13:53+00:00&quot;&gt;2020-12-29T18:13:53+00:00&lt;/span&gt;"><span class="localtime" data-ltformat="F j, Y" data-lttime="2020-12-29T18:13:53+00:00">December 29, 2020</span></span> <span class="localtime" data-ltformat="g:i a" data-lttime="2020-12-29T18:13:53+00:00">12:13 pm</span></time>
</div>
<div class="post-card-v3 post-card-v3__sharing">
<div class="post-card-v3__share-button post-card-v3__share-button--blank">
<div onclick="ga_universal('send', 'event', 'V3 - Related', 'Like', 'https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/')" class="fb-like" data-href="https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/" data-layout="button_count" data-action="like" data-size="small" data-show-faces="false" data-share="false"></div>
</div>
<div onclick="ga_universal('send', 'event', 'V3 - Related', 'Share', 'https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/')" data-link="https://rare.us/rare-news/donald-trump-michelle-obama-2020-admired-list/" class="rare-share post-card-v3__share-button"><svg class="icon"><use xlink:href="#icon-share-arrow"></use></svg> <span>| Share</span></div>
</div>
</div>
</div>
</div>
<script>

</script>
</span>
<span>
<div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_Desktop_MedRec_2" data-prebid="RARE_Desktop_MedRec_2" data-sizes="0x0:|1400x0:300x250,300x600" data-refresh="viewable" data-refresh-secs="45"></div></div> </span>

</span>
</div>
</div>
<div class="single-v3__container"><div class="single-v3__max-container"><article class="post-body-v3">
<div class="post-body-v3__image-wrap">
<img src="https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?w=1200&#038;h=800&#038;crop=1" alt="Man Gets Beaten With Twisted Tea After Yelling Racial Slurs" srcset="https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg 1200w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=150,100 150w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=300,200 300w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=768,512 768w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=1024,683 1024w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=260,173 260w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=891,594 891w, https://rare.us/wp-content/uploads/sites/3/2020/12/Man-Gets-Beatdown-With-Twisted-Tea-For-Saying-N-Word.jpg?resize=935,623 935w" sizes="(max-width: 1200px) 100vw, 1200px" />
<span class="rare-subtitle">Twitter via @terencessb</span>
<figcaption class="wp-caption-text"><a href="https://twitter.com/terencessb/status/1342002633679097858">Twitter via @terencessb</a></figcaption>
</div>

<div class="post-body-v3__text">
<p>We all know to really and truly be careful about what you ask for- because you just might actually get it. And in this case, this guy definitely deserved it. It is never okay to use the N-word, in <a href="https://rare.us/rare-news/walmart-brawl-ps5/"><strong>any situation by anyone</strong></a>, and this guy was not only asking to get his butt whooped by his actions but he stupidly,<a href="https://www.wideopeneats.com/iced-tea-recipes/"><strong> literally asked to get beat up</strong></a>.</p>
<p>This viral video shows a White man, seemingly wasted (and if not, then causing an unnecessary disturbance and ruckus) at a Circle K gas station in Elyria, Ohio, hurling profane words at the customer behind him, who is a Black man. The video reveals the White man making obscene sexual remarks about the Black man&#8217;s mother and <a href="https://rare.us/rare-news/virginia-hanging-racist-halloween-decorations/"><strong>hurling racial slurs</strong></a>, using the n-word freely.</p><div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_Desktop_Inline" data-prebid="RARE_Desktop_Inline" data-sizes="0x0:|768x0:1x1"></div></div>
<h2 style="text-align: center;">Customer Gets Beatdown With Twisted Tea For Saying N-Word</h2>
<div class="embed-twitter">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="ht" dir="ltr">JeeeeeeZUS LMAOOOOOOOOOOOO <a href="https://t.co/2P76jlT0sf">pic.twitter.com/2P76jlT0sf</a></p>
<p>&mdash; Terence (@terencessb) <a href="https://twitter.com/terencessb/status/1342002633679097858?ref_src=twsrc%5Etfw">December 24, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p></div>
<p>The Black man at first does his best to ignore this guy in front of him, because anyone with decent common sense wouldn&#8217;t waste their time on an idiot making racist slurs at a convenience store. But then the White customer just takes it too far. As the victim of the racial slurs grabs a can of Twisted Tea, which I assume he came to the Ohio gas station intending to grab a quick drink and go home to relax, the aggressor taunts his victim, literally asking him to smack him in the face.</p>
<p>The patient, but obviously irritated customer loads up into a cautioning stance, giving this idiot one more chance to actually shut up. But of course, the dumb-dumb keeps popping off, and so the tired customer goes at him with the spiked iced tea. The White man is totally thrown off, and as the fight continues on the floor, the Black man is clearly stronger and in more control of the situation.</p>
<p>&#8220;I asked you not to call me a [n-word],&#8221; he says, as he holds the perpetrator on the floor. He picks him up and whisks him off towards the exit, not entertaining the situation any longer.</p>
<p>I have no idea what makes it okay for this guy to do this in the city of Elyria, but this isn&#8217;t okay anywhere, ever. <a href="https://chroniclet.com/news/245981/viral-video-shows-fight-allegedly-in-elyria-convenience-store/"><strong>According to the Chronicle-telegram</strong></a>, a local newspaper, the incident was not reported to the police, but the video went viral on social media. One Twitter user commented,&#8221;This is what happens when y’all use the n-word freely. Others think it’s ok to. So when y’all make music whatever it is , just know they are listening and mimicking our language and adapting to it. Personally why I hate the word because I know this will happen.”</p><div class="single-v3__container single-v3__container--flex infinite-ad"><div id="" class="flex-ad text-center homepage-standard__block"> <div class="flex-ad__text rare-title">Advertisement</div> <div class="flex-ad__wrap"> <div class="ad-holder"><div class="htl-ad" data-unit="RARE_Desktop_Inline_Infinite" data-prebid="RARE_Desktop_Inline_Infinite" data-sizes="0x0:|768x0:300x250" data-refresh="viewable" data-refresh-secs="60" data-eager></div> </div> </div></div></div>
<h2 style="text-align: center;">Twitter User On Saying N-Word</h2>
<div class="embed-twitter">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">This is what happens when y’all use the n word freely. Others think it’s ok to. So when y’all make music whatever it is , just know they are listening and mimicking our language and adapting to it. Personally why I hate the word because I know this will happen</p>
<p>&mdash; 💛Honey💛 (@HoneybLved) <a href="https://twitter.com/HoneybLved/status/1342144174838194177?ref_src=twsrc%5Etfw">December 24, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p></div>
<p>And I won&#8217;t fail to mention that the reasonable guy was wearing a face mask, while his oppressor wasn&#8217;t. Let&#8217;s not forget that COVID is still haunting our country, but even a pandemic isn&#8217;t going to stop just because of a brawl. Nevertheless, this was handled with as much class as possible, and I have to hand it to the victim for keeping his cool and not wasting any more time than he needed to on someone like that.</p><div class="single-v3__container single-v3__container--flex infinite-ad"><div id="" class="flex-ad text-center homepage-standard__block"> <div class="flex-ad__text rare-title">Advertisement</div> <div class="flex-ad__wrap"> <div class="ad-holder"><div class="htl-ad" data-unit="RARE_Desktop_Inline_Infinite" data-prebid="RARE_Desktop_Inline_Infinite" data-sizes="0x0:|768x0:300x250" data-refresh="viewable" data-refresh-secs="60" data-eager></div> </div> </div></div></div>
<h2>Watch: <a href="https://rare.us/rare-news/woman-rants-at-asian-staff-canada/">Racist Woman Yells at Asian Drugstore Staff For “Speaking Chinese” in Front of Her</a></h2>
</div>
<div class="post-body-v3__video post-body-v3__video--rumble">
<div style="min-height: 360px; min-width: 315px;">
 <iframe id="rumble-vid" width="940" height="498" src="https://rumble.com/embed/vqsk0/?pub=4&#038;autoplay=2" frameborder="0" allowfullscreen></iframe>
</div>
<script type="text/javascript">
              !function(r,u,m,b,l,e){r._RumbleDotCom=b,r[b]||(r[b]=function(){
                (r[b]._=r[b]._||[]).push(arguments)}),l=u.createElement(m),e=u.getElementsByTagName(m)[0],
                l.async=1,l.src="//rumble.com/j/rumble.js",
                e.parentNode.insertBefore(l,e)}(window,document,"script","Rumble");
            </script>
<script src="https://rare.us/wp-content/themes/wom-rare-platform/assets/brands/rare/video.min.js"></script>
<div data-width="100%" data-height="500" data-aspect-ratio="1.7777777777778" data-widget="featured-video" data-code="" data-scalable="1"></div> </div>
<div class="post-body-v3__footer"><div class="author-card split alt">
<div class="author-card__item first">
<div class="author-card__block author-card__block--top">
<span class="author-card__image-wrap">
<img width="80px" height="80px" src="https://rare.us/wp-content/uploads/sites/3/2020/03/14c45a17-6e9c-45dd-9248-bd4505caeb94_1_201_a.jpeg?w=80&amp;h=80" alt="Lauren Pineda" />
</span>
<span class="author-card__label">About the author: </span>
<a rel="author" class="author-card__link rare-subtitle" href="https://rare.us/voices/lauren-pineda/">
Lauren Pineda<span class="author-card__role">, Staff Writer</span>
</a>
</div>
<div class="author-card__block">
<div class="author-card__desc">
Lauren Pineda is a writer with a background in music journalism and pop culture. Her best writing comes from her passion for storytelling and connecting her audience. She lives and breathes any live music show or art event and enjoys listening to peoples’ stories. </div>
<a class="author-card__cta rare-btn" href="https://rare.us/voices/lauren-pineda/">View More Articles</a>
</div>
</div>
</div>
</div></article>
</div></div><div class="single-v3__container--flex single-v3__container"> <ul class="tag-list">
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/black-man/" title="black man">
black man </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/brawl/" title="brawl">
brawl </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/convenience-store/" title="convenience store">
convenience store </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/covid/" title="CoVid">
CoVid </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/gas-station/" title="gas station">
gas station </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/ohio/" title="Ohio">
Ohio </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/pandemic/" title="Pandemic">
Pandemic </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/social-media/" title="Social media">
Social media </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/video-shows/" title="Video Shows">
Video Shows </a>
</li>
<li class="tag-list__item">
<a class="rare-tag" href="https://rare.us/tag/viral-video/" title="viral video">
viral video </a>
</li>
</ul>
</div>
<div class="single-v3__container single-v3__util">

<p id="native-ad" class="native-ad"></p>
<div id="" class="text-center homepage-standard__block"><div class="htl-ad" data-unit="RARE_1x1_Desktop" data-prebid="RARE_1x1_Desktop" data-sizes="0x0:|768x0:1x1"></div></div>
<div class="single-v3__max-container">
<h4 class="single-v3__header rare-title">Stories You Might Like</h4>

<div class="single-v3__newsfeed">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
                      window._taboola = window._taboola || [];
                      _taboola.push({
                        mode: 'thumbnails-a',
                        container: 'taboola-below-article-thumbnails',
                        placement: 'Below Article Thumbnails',
                        target_type: 'mix'
                      });
                    </script>
</div>
</div>
</div>
</main>

</div>
<footer class="footer brand-gradient">
<div class="footer__breadcrumbs">
</div>
<div class="container container-flush--sm">
<div class="layout horizontal-reverse-md footer__inner">
<div class="flex-1 self-center">
<div class="footer__copy">
<div class="copyright">
&copy; 2013 - 2020 Wide Open Media Group
<span class="mobile-break">
<span class="hidden-xs">|</span> Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=rare.us" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a> </span>
</div>
</div>
</div>
<div class="flex-1 self-center">
<div class="footer__nav">
<div class="footer-link-list"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-905536" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-905536 about"><a href="https://rare.us/what-is-rare/">About</a></li>
<li id="menu-item-929489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-929489 ad-preferences"><a href="https://optout.networkadvertising.org/?c=1">Ad Preferences</a></li>
<li id="menu-item-890538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-890538 advertise"><a href="https://www.wideopenmediagroup.com/advertise/">Advertise</a></li>
<li id="menu-item-905543" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-905543 corrections-policy"><a href="https://rare.us/corrections-policy/">Corrections Policy</a></li>
<li id="menu-item-933706" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-933706 privacy-policy"><a href="https://privacy.wideopenmediagroup.com/">Privacy Policy</a></li>
<li id="menu-item-545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-545 visitor-agreement"><a href="https://rare.us/visitor-agreement/">Visitor Agreement</a></li>
<li id="menu-item-933707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-933707 do-not-sell-my-personal-information"><a href="https://accounts.wideopenmediagroup.com/do-not-sell?src=WOMRARE&#038;site=RAR">Do Not Sell My Personal Information</a></li>
</ul></div> </div>
</div>
</div>
</div>
</footer>
</div>
</div>
<div id="amzn-assoc-ad-99deb2ea-5f18-4042-a816-0550ee09396c"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=99deb2ea-5f18-4042-a816-0550ee09396c"></script>

<script>
    (function() {
      var cx = "013646479992326286830:s9hsgmrdsau";
      var gcse = document.createElement('script');
      gcse.type = 'text/javascript';
      gcse.async = true;
      gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
          '//cse.google.com/cse.js?cx=' + cx;
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(gcse, s);
    })();
  </script>
<script>
		( function( $ ) {
				var iFrames = $('.rare-widget--calc');
				function iResize() {
					for (var i = 0, j = iFrames.length; i < j; i++) {
						iFrames[i].style.height = iFrames[i].contentWindow.document.body.offsetHeight + 'px';}
					}
					if ($.browser.safari || $.browser.opera) {

						 iFrames.load(function(){
							 setTimeout(iResize, 0);
						 });

						 for (var i = 0, j = iFrames.length; i < j; i++) {
							var iSource = iFrames[i].src;
							iFrames[i].src = '';
							iFrames[i].src = iSource;
						 }
					} else {
						 iFrames.load(function() {
							 this.style.height = this.contentWindow.document.body.offsetHeight + 'px';
						 });
					}
		} )( jQuery );
	</script>
<script type="text/javascript">  _qevents.push( { qacct:"p-E2kxRT9Lk59KK"} );</script><noscript>      <div style="display: none;">          <img src="//pixel.quantserve.com/pixel/p-E2kxRT9Lk59KK.gif" height="1" width="1" alt="Quantcast"/>      </div></noscript>
<script type="text/javascript">
// 86acbd31cd7c09cf30acb66d2fbedc91daa48b86:1512074742.5
!function(n,t,c,e,u){function r(n){try{f=n(u)}catch(n){return h=n,void i(p,n)}i(s,f)}function i(n,t){for(var c=0;c<n.length;c++)d(n[c],t);
}function o(n,t){return n&&(f?d(n,f):s.push(n)),t&&(h?d(t,h):p.push(t)),l}function a(n){return o(!1,n)}function d(t,c){
n.setTimeout(function(){t(c)},0)}var f,h,s=[],p=[],l={then:o,catch:a,_setup:r};n[e]=l;var v=t.createElement("script");
v.src=c,v.async=!0,v.id="_uasdk",v.rel=e,t.head.appendChild(v)}(window,document,'https://web-sdk.urbanairship.com/notify/v1/ua-sdk.min.js',
	'UA', {
		appKey: "d11SwiyrQ8OKQt0up6YCJA",
		token: "MTpkMTFTd2l5clE4T0tRdDB1cDZZQ0pBOnBNbXRRVi1iWHlnYThhRkxMTm9PZmRHZmczS0VnTXBXbmI2Y2hKd2xMa3M",
		vapidPublicKey: "BOtZmSaQHaO53ghRX4GBXB82R7w7u8RgrpBhI30WiH4lXzC7QG-cp-werP1xKwMExyKJwZOv7HT-Shelpea_v4k=",
		workerUrl: "/wp-content/themes/wom-rare-platform/inc/plugins/urbanairship/worker/push-worker-rare.js"	});

</script>
<script type='text/javascript' src='https://rare.us/wp-content/themes/wom-rare-platform/js/skip-link-focus-fix.js?m=1593395549g'></script>
<script src='//cdnjs.cloudflare.com/ajax/libs/lodash.js/4.6.1/lodash.min.js?ver=2.1' id='rare-lodash-js'></script>
<script src='https://content.jwplatform.com/libraries/swuoApzE.js?ver=20180725' id='jwplayer-cloud-16_9-js'></script>
<script type='text/javascript' src='https://rare.us/_static/??-eJydzbFOAzEMBuAXImcK9JgQI1M3XiCXuE1OdpzaCRVvT6q2QyUWmGzL+r8fTtUFKQ1Lg5aQ0eAk7NQrukq+7UUZvBk2g0V9iQaWxjOC5XIgdF/PbgQmzmVa7QH+zTW/iJB3e5GG+icvlwCV+iEXg66LLz6rpVzvDpeQ6oCv6MhQj4Nb7XwiLxh/Kw2Ux3Dc3a3h3B+EWcZuGmAnsRPCx+cOFE26hou6Hjvq92RBhShibenqv/PbZn58fZnnp812/QHaVo/j'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202053.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2.1',blog:'169527222',post:'939282',tz:'-6',srv:'rare.us'} ]);
	_stq.push([ 'clickTrackerInit', '169527222', '939282' ]);
</script>
</body>
</html>
